[BUG?] match_phrase_prefix failing on v1.1.0, working on 1.0.2

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[BUG?] match_phrase_prefix failing on v1.1.0, working on 1.0.2

Michal Barla
Hello everyone,

I am using match_phrase_prefix query and was surprised that after updating to 1.1.0 my tests got broken.

Here is a small test case which works on 1.0.2 (returns a hit) and fails (0 hits) on 1.1.0.

https://gist.github.com/crutch/04cd5acbd84eee04d683

I did not find any mention about breaking changes concerning match_phrase_prefix on a web page...

Is there something I have missed or is it a bug?

-- 
Michal Barla

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0bfc9aaa-4df9-45d6-988a-b7e8a2b17fed%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [BUG?] match_phrase_prefix failing on v1.1.0, working on 1.0.2

Binh Ly-2
Yes, it's a bug and will be fixed shortly. Related to this:

https://github.com/elasticsearch/elasticsearch/issues/5437

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/03a290c6-4835-4bf7-968e-b81f7361e639%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [BUG?] match_phrase_prefix failing on v1.1.0, working on 1.0.2

Michal Barla
OK, thanks. I've found that #5437 (it is linked from release notes) but since it is discussing slopes I did not consider it relevant for my case.

On Wednesday, March 26, 2014 2:49:35 PM UTC+1, Binh Ly wrote:
Yes, it's a bug and will be fixed shortly. Related to this:

<a href="https://github.com/elasticsearch/elasticsearch/issues/5437" target="_blank" onmousedown="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Felasticsearch%2Felasticsearch%2Fissues%2F5437\46sa\75D\46sntz\0751\46usg\75AFQjCNFK46BIA-_HSr3k7i7xWKFVUmxt5g';return true;" onclick="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Felasticsearch%2Felasticsearch%2Fissues%2F5437\46sa\75D\46sntz\0751\46usg\75AFQjCNFK46BIA-_HSr3k7i7xWKFVUmxt5g';return true;">https://github.com/elasticsearch/elasticsearch/issues/5437

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/45b1cd17-8c90-4146-b221-3e255a5b37cf%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [BUG?] match_phrase_prefix failing on v1.1.0, working on 1.0.2

Binh Ly-2
I will open another issue for this shortly. :)

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f928611e-47af-4e3a-98b0-0b0baa29b628%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [BUG?] match_phrase_prefix failing on v1.1.0, working on 1.0.2

simonw-2
In reply to this post by Michal Barla
It's actually unrelated to this issue mentioned above. It got broken due to https://github.com/elasticsearch/elasticsearch/pull/5005
and there is an issue open here: https://github.com/elasticsearch/elasticsearch/issues/5551 a fix is right here: https://github.com/elasticsearch/elasticsearch/issues/5553

simon
On Wednesday, March 26, 2014 3:00:28 PM UTC+1, Michal Barla wrote:
OK, thanks. I've found that #5437 (it is linked from release notes) but since it is discussing slopes I did not consider it relevant for my case.

On Wednesday, March 26, 2014 2:49:35 PM UTC+1, Binh Ly wrote:
Yes, it's a bug and will be fixed shortly. Related to this:

<a href="https://github.com/elasticsearch/elasticsearch/issues/5437" target="_blank" onmousedown="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Felasticsearch%2Felasticsearch%2Fissues%2F5437\46sa\75D\46sntz\0751\46usg\75AFQjCNFK46BIA-_HSr3k7i7xWKFVUmxt5g';return true;" onclick="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Felasticsearch%2Felasticsearch%2Fissues%2F5437\46sa\75D\46sntz\0751\46usg\75AFQjCNFK46BIA-_HSr3k7i7xWKFVUmxt5g';return true;">https://github.com/elasticsearch/elasticsearch/issues/5437

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/dbcdb2ae-d030-4b25-b6d1-a47e7f15986b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.