Discovery and/or Reconnection

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Discovery and/or Reconnection

Kenneth Loafman
Hi,

I've got two nodes running and communicating, or rather I did until the
network went down for a long while.  Now, I have two independent
clusters of one node each.  How do I get the nodes to rejoin into a
cluster?  Does this require a manual service restart?  The network has
been up and running for an hour now and the logs show no sign of
reconnect attempts.

...Thanks,
...Ken

Reply | Threaded
Open this post in threaded view
|

Re: Discovery and/or Reconnection

kimchy
Administrator
Yes, currently, the there is no auto join and you simply need to restart the isolated node so it will join back to the cluster.

-shay.banon

On Wed, Jul 14, 2010 at 4:18 PM, Kenneth Loafman <[hidden email]> wrote:
Hi,

I've got two nodes running and communicating, or rather I did until the
network went down for a long while.  Now, I have two independent
clusters of one node each.  How do I get the nodes to rejoin into a
cluster?  Does this require a manual service restart?  The network has
been up and running for an hour now and the logs show no sign of
reconnect attempts.

...Thanks,
...Ken


Reply | Threaded
Open this post in threaded view
|

Re: Discovery and/or Reconnection

John Chang
Was this perhaps fixed in 0.9?  Under 0.8, I saw my client (ie no-data) nodes not reconnecting to the main cluster nodes (ie. data nodes) in they went down and came back up.  However, now under 0.9, the client nodes seem to magically reconnect if the data nodes go down and come back.

Or, if 0.9 doesn't fix this (I'd be surprised...it seems to), how should I handle this?  Do I still need to restart the client nodes?  Or can I catch exceptions and re-connect (which, actually, I was doing under 0.8 and it seemed to work).

Thanks.
Reply | Threaded
Open this post in threaded view
|

Re: Discovery and/or Reconnection

kimchy
Administrator
Client nodes do reconnect since 0.9.

On Wed, Sep 1, 2010 at 9:09 PM, John Chang <[hidden email]> wrote:

Was this perhaps fixed in 0.9?  Under 0.8, I saw my client (ie no-data) nodes
not reconnecting to the main cluster nodes (ie. data nodes) in they went
down and came back up.  However, now under 0.9, the client nodes seem to
magically reconnect if the data nodes go down and come back.

Or, if 0.9 doesn't fix this (I'd be surprised...it seems to), how should I
handle this?  Do I still need to restart the client nodes?  Or can I catch
exceptions and re-connect (which, actually, I was doing under 0.8 and it
seemed to work).

Thanks.
--
View this message in context: http://elasticsearch-users.115913.n3.nabble.com/Discovery-and-or-Reconnection-tp966417p1401924.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.