Only running flush and then clear cache clears heap memory

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Only running flush and then clear cache clears heap memory

oreno
This post has NOT been accepted by the mailing list yet.
This post was updated on .
Hello,
for a long time now I've been trying to tune the heap size of our elasticsearch cluster.
I'm loading  ~200g on a 2 node cluster , each with 8 cores + 60g Ram (heap size set to 30g).

While loading data the gc size gets smaller and smaller until it gets out of memory after ~100g is loaded.
I'm not running any queries therefore cache field & filter are empty.
Flush setting was not changed at all (default).

As part of my attempts to figure this out I tried running both flush and clear cache separately, but it didn't do any good. Which make sense because there's nothing in the cache and flush is running by default setting.

But... when I ran flush and then clear cache, the heap size suddenly dropped from 28g to 2g!
What I'm trying to understand is why this combination finally did the trick (as I said cache was empty),
and what settings should I use so that will not require manual execution. Because clearly memory is being
abused in some way...  

Thoughts anyone?

Thanks in advance